Cling MediaRenderer can't be seen by Workbench

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Cling MediaRenderer can't be seen by Workbench

phu_nguyen

Hi all,
I receive this exception when starting the Cling MediaRenderer.

SEVERE - 16:58:15:640 - Thread-6 : null : Initialization failed: org.teleal.cling.binding.LocalServiceBindingException: State variable '(StateVariable, Name: VolumeDB, Type: i2) (No Events)' datatype can't handle action argument's Java type (change one): class java.lang.Short
SEVERE - 16:58:15:640 - Thread-6 : null : Cause: org.teleal.cling.binding.LocalServiceBindingException: State variable '(StateVariable, Name: VolumeDB, Type: i2) (No Events)' datatype can't handle action argument's Java type (change one): class java.lang.Short

I use Cling Workbench to scan that, and could not see the Clinq MediaRenderer.

Can any one help me?

Sorry for my English :(
Thanks & Best Regards,
Phú Nguyễn
Reply | Threaded
Open this post in threaded view
|

Re: Cling MediaRenderer can't be seen by Workbench

Christian Bauer
Administrator
Yep, that's broken. Didn't notice before the 1.0.4 release. It might be fixed in 1.1 snapshot but I'm not sure.
Reply | Threaded
Open this post in threaded view
|

Re: Cling MediaRenderer can't be seen by Workbench

phu_nguyen
Hi,
So Cling Workbench cannot see the Cling MediaRenderer becausof that exception, right?
Do you have any workaround for this issue?

Thanks,
Thanks & Best Regards,
Phú Nguyễn
Reply | Threaded
Open this post in threaded view
|

Re: Cling MediaRenderer can't be seen by Workbench

Christian Bauer
Administrator
Download 1.0.5.
Reply | Threaded
Open this post in threaded view
|

Re: Cling MediaRenderer can't be seen by Workbench

phu_nguyen
It work fine!  
Thank a lot !!!!
Thanks & Best Regards,
Phú Nguyễn
Reply | Threaded
Open this post in threaded view
|

Re: Cling MediaRenderer can't be seen by Workbench

Kamil_tt
This post was updated on .
Hi,
When run "Cling MediaRender", show  errors  
SEVERE - 10:10:51:062 - Thread-8 : null : Initialization failed: java.lang.UnsatisfiedLinkError: Could not load library gstreamer-0.10
SEVERE - 10:10:51:062 - Thread-8 : null : Cause: java.lang.UnsatisfiedLinkError: Could not load library gstreamer-0.10

I try run Cling mediarender version 1.0.5 and 2.0.3 on Windows 7.
java -Djna.library.path=D:/gstreamer/1.0/x86/lib -jar cling-mediarenderer-2.0-alpha3-standalone.jar
Instaled gstreamer link
 
Workbench don't see MediaRender.
How to run correctly MediaRender?